Tomcat Server Cluster

0 értékelés
122 megtekintés
Turan79 (32 pont) kérdezte Szep 7.

Sziasztok,

gyakorlásképpen próbálok Tomcat server clustert létrehozni egy udemy-s tanfolyam alapján. A Tomcat server megy minden gond nélkül. Ha valamelyik instance-t szeretném inditani, akkor a 404-es hibaüzenettel leáll.

192.168.1.9 - - [06/Sep/2020:01:37:50 +0200] "GET / HTTP/1.1" 200 11415
192.168.1.9 - - [06/Sep/2020:01:37:50 +0200] "GET / HTTP/1.1" 200 11415
192.168.1.9 - - [06/Sep/2020:01:37:58 +0200] "GET /HNAP1/ HTTP/1.1" 404 761

az instance startup-ja a következő:

SET CATALINA_HOME=C:\tomcat\tomcat9\apache-tomcat-9.0.37\
SET CATALINA_BASE=C:\tomcat\tomcat9\Instance1

"C:\tomcat\tomcat9\Instance1"
cd %CATALINA_HOME%\bin
startup.bat
::"C:\tomcat\tomcat9\apache-tomcat-9.0.37\bin\startup.bat"

a classpathok jók, többször ellenőriztem.

Te nem tudod ez mitől lehet?
Köszönöm!

server.xml:
https://pastebin.com/rSN6qZUU

1 Válasz

0 értékelés
Turan79 (32 pont) válaszolta meg Szep 7.
Turan79 kiválasztva Szep 7.
 
Legjobb válasz

Sziasztok,

megtaláltam a hibát. Az instance-ok server.xml beállitásában voltak olyan hostok felsorolva, melyek már nem léteztek. Amikor ezeket ki kommenteltem indult:

  1. <Host name="www.website1.com" appBase="website1-webapp"
  2. unpackWARs="true" autoDeploy="true"/>
  3. <Host name="www.website2.com" appBase="website2-webapp"
  4. unpackWARs="true" autoDeploy="true"/>
  5. <Host name="www.website3.com" appBase="website3-webapp"
  6. unpackWARs="true" autoDeploy="true"/>
...